"more extra formal parameters "

A place for discussing topics that do not fit into the other VGS categories

"more extra formal parameters "

Postby jyoung » Wed Apr 08, 2009 11:22 am

The error occurs during the build in T-Vec and occurs 20+ times whith the only difference being the RP number.


Loading project D:\Documents and Settings\jyoung\My Documents\jyoung\tvec\Test Folder\Norm_test2\norm_tvec2.prj...
IfBlock_108_action_1
IfBlock_108_action_else
IfBlock_180_action_1
IfBlock_180_action_else
IfBlock_36_action_1
IfBlock_36_action_else
norm_tvec2_root
If_Action_Subsystem__a
__coreRTS
__relationalOpGTB
__runTimeData
Done.
Validating import list...
Done.
Checking project options...Done
Expanding inheritance structures...Done
Setting up build tasks...Done
Attempting to checkout Core license...Done
Initiating Build.
Compilation Up To Date : __coreRTS
Compiling Subsystem : __runTimeData...Done.
Compiling Subsystem : IfBlock_108_action_1...Done.
Generating Vectors : IfBlock_108_action_1...Done.
Analyzing Coverage : IfBlock_108_action_1...Done.
Saving Vectors as HTML : IfBlock_108_action_1...Done.
Saving Vectors as XML : IfBlock_108_action_1...Done.
Compiling Subsystem : IfBlock_108_action_else...Done.
Generating Vectors : IfBlock_108_action_else...Done.
Analyzing Coverage : IfBlock_108_action_else...Done.
Saving Vectors as HTML : IfBlock_108_action_else...Done.
Saving Vectors as XML : IfBlock_108_action_else...Done.
Compiling Subsystem : IfBlock_180_action_1...Done.
Generating Vectors : IfBlock_180_action_1...Done.
Analyzing Coverage : IfBlock_180_action_1...Done.
Saving Vectors as HTML : IfBlock_180_action_1...Done.
Saving Vectors as XML : IfBlock_180_action_1...Done.
Compiling Subsystem : IfBlock_180_action_else...Done.
Generating Vectors : IfBlock_180_action_else...Done.
Analyzing Coverage : IfBlock_180_action_else...Done.
Saving Vectors as HTML : IfBlock_180_action_else...Done.
Saving Vectors as XML : IfBlock_180_action_else...Done.
Compiling Subsystem : IfBlock_36_action_1...Done.
Generating Vectors : IfBlock_36_action_1...Done.
Analyzing Coverage : IfBlock_36_action_1...Done.
Saving Vectors as HTML : IfBlock_36_action_1...Done.
Saving Vectors as XML : IfBlock_36_action_1...Done.
Compiling Subsystem : IfBlock_36_action_else...Done.
Generating Vectors : IfBlock_36_action_else...Done.
Analyzing Coverage : IfBlock_36_action_else...Done.
Saving Vectors as HTML : IfBlock_36_action_else...Done.
Saving Vectors as XML : IfBlock_36_action_else...Done.
Compilation Up To Date : __relationalOpGTB
Compiling Subsystem : norm_tvec2_root...
ERROR : CF0039 :
Utility function reference -> IfBlock_108_action_else
has one or more extra formal parameters in its parameter list
starting with parameter -> v_rel_h_1_1
than does the actual parameter list in the reference to the
utility made within -> RP48
at ss file location -> ./specifications\norm_tvec2_root.SS(4407,80)

Code
*******************************************
function y = util_vec_unitize(b)
y = [0 0 0]';

vMag = sqrt(b(1)^2+b(2)^2+b(3)^2);

if vMag > 0.0
y = b/vMag;
else
end

return
jyoung
 
Posts: 33
Joined: Wed Mar 18, 2009 2:25 pm

Re: "more extra formal parameters "

Postby busser » Wed Apr 08, 2009 11:34 am

This type of error

ERROR : CF0039 :
Utility function reference -> IfBlock_108_action_else
has one or more extra formal parameters in its parameter list
starting with parameter -> v_rel_h_1_1
than does the actual parameter list in the reference to the
utility made within -> RP48
at ss file location -> ./specifications\norm_tvec2_root.SS(4407,80)

when produced by the t-vec compiler points to a situation where the reference to a lower level subsystem, in your case called "IfBlock_108_action_else" because that is the name you placed on the subsystem block, has a different number of actual parameters than the actual "IfBlock_108_action_else" subsystem expects. This is analogous to a function prototype like

int func(int x, int y);

and a reference to it like this

func(1, 2, 3)

Unless it was hand-modified, which I don't expect to the the case in your example, it indicates a model translation problem. This should not normally occur.

Can you forward your model to us for analysis and correction of this translation problem ?
busser
Site Admin
 
Posts: 52
Joined: Thu Mar 13, 2008 7:42 pm

Re: "more extra formal parameters "

Postby busser » Wed Apr 08, 2009 2:52 pm

The model you sent helped to identify the issue. The version of Simulink Tester that you are using includes only a beta level support for EML. This problem you are experiencing is due to an issue with the EML support in that version. The translator was not handling a number of issues correctly. The good news is that your model translates and runs fine in the latest builds of the tools and will be available in the next release. I'll look into getting you pre-release version asap.
busser
Site Admin
 
Posts: 52
Joined: Thu Mar 13, 2008 7:42 pm

Re: "more extra formal parameters "

Postby jyoung » Wed Apr 08, 2009 2:59 pm

Bob that would be excellent

Thanks
jyoung
 
Posts: 33
Joined: Wed Mar 18, 2009 2:25 pm


Return to General Topics

Who is online

Users browsing this forum: No registered users and 1 guest

cron